Unable to satisfy the following requirements解决方案

              今天从git上面download我们项目,然后向往常一样安装Cocoapods,但是却突然发现报错了,尝试了几遍,发现一直报错。然后我这才看了一下,安装Cocoapods的日志,发现抛出了一个报错。

方案

[!] Unable to satisfy the following requirements:

- `MJExtension` required by `Podfile` - `MJExtension (= 2.4.4)` required by `Podfile.lock`
              哎,之前没有见过这个错误,我不知道从何着手解决这个问题。然后,开始使用我们程序员的神器,就是Google啦。很难想象如果没有Google,多少程序员要丢饭碗。看到了一个博客分享了自己的解决方案,如下:

因此我们要用pod命令进行安装。cd到Example目录下执行pod install命令,将会报错:

[plain] view plaincopy解决unable
  1. $ pod install  
  2. Analyzing dependencies  
  3. Fetching podspec for `UAAppReviewManager` from `..`  
  4. [!] Unable to satisfy the following requirements:  
  5. - `UAAppReviewManager (from `..`)` required by `Podfile`  


原因是要添加的类库已经有最新版本推出,而Podfile文件并没有更改其下载版本(Podfile文件过期),于是获取安装数据失败。

因此我们要用update命令获取最新版本的类库:

[plain] view plaincopyunablesatisfy
  1. $ pod update  
  2. Analyzing dependencies  
  3. Fetching podspec for `UAAppReviewManager` from `..`  
  4. Downloading dependencies  
  5. Installing UAAppReviewManager (0.2.1)  
                    由此可知,出现这个错误的原因是,我本地Podfile文件上的MJExtension第三方版本太低。解决方案就是,更新一下本地Podfile文件上的MJExtension第三方版本,也就是pod update --verbose一下。注意一下,这个命令需要很长时间。一直停在这个页面。。。。

zuodeMacBook-Air:mokodreamwork_ios2 zuo$ pod update --verbose Update all pods
  Preparing


Updating local specs repositories


Updating spec repo `master`
          大家千万不要关掉页面,等半个小时吧,就会更新好。如下界面:
thefollowing

       表示更新成功,问题也解决了,然后就可以打开我们从git上面download的工程了。          本文参考资料
       使用CocoaPods(一)为项目配置第三方类库

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关信息

更多
您的回应...

相关话题

查看全部

也许你感兴趣

换一批

热门标签

更多