Ruby 1.9.2正式发布 Socket API已支持IPv6

近日,Ruby 1.9系列的最新版本Ruby 1.9.2已经正式发布了,该版本与1.9.1的大部分是兼容的。Ruby 1.9.2的99%都通过了RubySpec,并且相比于1.8.x系列,Ruby 1.9.2在性能上有了显著的提高。

有趣的是,Ruby 1.9.2只是对英特尔32位架构的Debian Linux提供了全面的支持,而对OS X 10.5、10.6、FreeBSD、Windows以及Solaris视为“尽最大努力去支持”。

Ruby 1.9.2在Linux与Windows上的对比 
Ruby 1.9.2在Linux与Windows上的对比

Ruby 1.9.2主要改进:

◆增加了许多新方法;

◆新的socket API(支持IPv6);

◆新的随机数生成器;

◆增加了新的编码;

◆不会再出现2038年的问题;

下载及安装:

您可以从官方网站上下载相关资源:

http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p0.tar.gz

http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p0.tar.bz2

http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p0.zip

或者,您也可以使用RVM,最新版本的RVM支持Ruby 1.9.2:

rvm update --head && rvm reload && rvm install 1.9.2 && rvm 1.9.2 --default

更多Ruby 1.9.2新特性(英文),请访问这里

您的回应...

相关话题

查看全部

也许你感兴趣

换一批

热门标签

更多