linux下安装mongodb报错,找不到GCC
2013-12-05 来自:波西米亚 1 人回应

linux下安装mongodb时
执行 ./mongod --dbpath=../data/mongodb_data/ --logpath=../data/mongodb_log/mongodb.log --logappend

报错如下:
./mongod: /lib64/libgcc_s.so.1: version GCC_4.0.0' not found (required by ./mongod) ./mongod: /usr/lib64/libstdc++.so.6: versionCXXABI_1.3.1' not found (required by ./mongod)

是在云开发机上,我没有root权限,求熟悉的朋友解答
PS:mongod命令能不能指定gcc的路径,我在权限内装一个gcc是否可行

2013-12-08 来自:陈渣渣

应该是版本不对,要GCC 4.0.0或以上。

如果不想安装的话,可以下载合适版本的libstdc++.so.6,libgcc_s.so.1,放在一个目录,然后在环境变量LD_LIBRARY_PATH里增加这个目录。

您的回应

你还未登陆,不能回应!登陆